computer-related AVCHD problems

Hi,

I'm pretty new to using my Panasonic HC-X1 and have been experiencing a strange problem with using the AVCHD footage from it.

I edited a couple of quick projects on Vegas a month or two ago and everything worked fine. However, I went to start editing a new project shot on the same camera in the same 1080p 50fps AVCHD format and the footage wasn't importing properly from the memory card. It imported the MTS files onto my hard drive but the clips weren't appearing in my bin. When I then tried to bring them into my timeline from the hard drive instead only the audio track would appear.

I was first worried my footage or card was corrupted but later realised that now none of my old AVCHD projects would play the footage I'd previously worked with either! The audio works on the MTS files imported through Vegas but the video tracks have all been disabled from every project on my system using AVCHD files from the camera.

I've complained to Magix about Vegas and they've been looking into it to no avail.

Another twist in the tale - I tried installing Avid Media Composer First (the 'lite' free version) on my system to test that and again the AVCHD files wouldn't work. So it appears to be a system issue rather than a Vegas specific issue.

But what makes this even more strange is that both VLC and Windows Media Player will play the MTS files saved on the hard drive without issue. I've tried converting the files using VLC and those worked on Vegas too. I don't want to have to rely on this method though.

It's so strange and I wondered if anyone had any idea what might be causing the problem.

I'm not aware of any major changes to my system other than maybe a Windows 10 update. I tried updating my graphics card driver and updated Windows again, but no change.

System details:
OS Name Microsoft Windows 10 Home N
Version 10.0.18363 Build 18363
System Name DESKTOP-LP7L625
System Manufacturer ASUS
System Type x64-based PC
Processor Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM) 16.0 GB

Thanks

David
 

indietalk

IndieTalk Founder
Staff Member
Admin
Hello, if these happen to be large files, you will need to connect your camera and navigate to the storage folder and drag them onto your drive, and not use the import function.

But hmm you said old clips don't play. Perhaps try this at least.
 
Some are large files but not all of them. Quite a few were tiny and yes the weird thing is that the old files did work fine but now suddenly don't. Plus they play fine in VLC and Windows Media Player. It's baffling. It's a PC I haven't used for long (I usually use a Macbook Pro) but it's a few years old. It's fairly powerful though so performance shouldn't be an issue.
 
Thanks - it might be worth a look, though I've already managed to convert them using VLC and that seemed to work. I'm mainly bothered by the fact that it used to work but now doesn't though. Plus I'd rather not have to convert my files all the time if I don't have to, as it slows down my workflow and doubles up hard drive space.

Thanks for the help though, it's appreciated.
 
Thanks, though it looks like it's another advert for the pav converter. I guess I'll just have to live with converting the files or shooting in a different format. It's not the end of the world, it just bugs me that it did work at one point.
 

indietalk

IndieTalk Founder
Staff Member
Admin
Oops! That's what sucks about google searches, and me not reading too far...
 
I've fixed it!

I'd tried a simple uninstall and re-install without success pretty early on, but today I did an extremely thorough erase of the programme, getting rid of every trace on my hard drive, along with all other Magix video software I had on the system and even cleaned the registry and it works again!

God knows what happened and whether it will happen again, but for the time being it works.
 
Top