AMD Muliti Core problem in AE?

Hi all.

I have a AMD 4400+ 2.6 GHZ Dual Core CPU.
I have 4 GB ram installed, only 3 recognized by my XP32 bit OS.
I have the 3GB flag on in the boot.ini (FYI noobs, this lets AE CS3 use more that 2GB mem)
I have one TB of Raid0 SATA disk space (wohot!) for video only (OS is on its own IDE disk)
I have a nVidia GTX260 video card

so far so good, an ok system and I dont work it that hard with my SD AE stuff. (thats a presumption not a statement of fact!)


Problem:
With Mulit processor ON:
I hit the RAM PREVIEW (full screen) button, it renders, says done, but the system just waits for a minute or two... then plays back the footage smoothly. (single stream of SD video, or big comp, doesn't matter.. )

Now, If I turn OFF multiprocessor in the options, my renders take longer, but I don't get the hang at the end.


The Net effects seems that it takes the same amount of time to see the rendered video with 1 or 2 cores used by AE.. thats funny.. lol


Question:
What settings do I use for the OPEN GL preview dialog?

Thanks Will (my guess is you'll be first to answer!)
 
Thanks Will (my guess is you'll be first to answer!)

:lol:

I've got CS4, so my settings might be slightly different, but in the Previews section of the preferences menu I've got Adaptive resolution limit set to 1/4, and have Enable OpenGL, Enable Adaptive Resolution with OpenGL and Accellerate Effects with openGL all checked..

In the Memory & Multiprocessing tab, I have the slider set halfway between faster renders and longer preview.

Of course my system is somewhat different than yours, with the quad core chip, 12 gig of ram and 64bit operating system, so you might need to use different settings to make things work as smoothly as possible.

First thing I would verify though is that you have the latest video driver installed from nVidia.. get it from the nvidia website, don't rely on the microsoft distributed drivers that windows update can provide.

I believe a new driver was released within the last several months, so it would be worth looking into that.

As for the delay, how are you initiating your preview? Are you using the little transport control on the preview menu, or hitting 0 on the number pad on your keyboard? I've noticed that hitting 0 on the keyboard to start a ram preview render, and then hitting 0 again before it finishes rendering all it can will stop rendering and initiate playback of the ram preview right away, that might be a way around this issue for you.

I've honestly never experienced this, so can't offer you much other help than maybe to post in the adobe forums
 
Answers in line..

:lol:

I've got CS4, so my settings might be slightly different, but in the Previews section of the preferences menu I've got Adaptive resolution limit set to 1/4, and have Enable OpenGL, Enable Adaptive Resolution with OpenGL and Accellerate Effects with openGL all checked..

On my Previews section I see a "settings" button under the use open GL checkboxk.. it ask for how much video memory to use.. Im not sure what I should set in there..



In the Memory & Multiprocessing tab, I have the slider set halfway between faster renders and longer preview.


C3 doesnt have that slider.. :(

Of course my system is somewhat different than yours, with the quad core chip, 12 gig of ram and 64bit operating system, so you might need to use different settings to make things work as smoothly as possible.

you poor poor man.. ;)


First thing I would verify though is that you have the latest video driver installed from nVidia.. get it from the nvidia website, don't rely on the microsoft distributed drivers that windows update can provide.

I believe a new driver was released within the last several months, so it would be worth looking into that.

Yup, downloaded last week..

As for the delay, how are you initiating your preview? Are you using the little transport control on the preview menu, or hitting 0 on the number pad on your keyboard? I've noticed that hitting 0 on the keyboard to start a ram preview render, and then hitting 0 again before it finishes rendering all it can will stop rendering and initiate playback of the ram preview right away, that might be a way around this issue for you.


via the button on the screen.. the same behavior if I do 0 though.. and even if I only render part of the clip, hit 0 ( or just click the mouse) I get the delay before it starts playing back..

I've honestly never experienced this, so can't offer you much other help than maybe to post in the adobe forums

Thanks for the ideas..
 
Hmm..

I think you'll have to play around with the number for the amount of video memory to use until you find what works best for you. It's really more of a trial & error kind of thing than an exact science with AE. ;)
 
UPDATE: Issue resolved, posted for posterity:

While trying to debug a different issue, I discovered several versions of quick time installed on my system, in fact, the one that was associated with MOV files was some ancient version that looks like it came from win98 days! I uninstalled every quicktime version I found. Downloaded the latest Quicktime and purchased the pro version registration (good idea anyway as I can off load my "delivery" renders on to it, $20 not to bad for peace of mind)

Now, my ram previews work great, and faster now that I can use both cores.
Thanks
 
Top